Re: [androidbrasil-dev] [off-topic] perguntas expostas no google

eu ja vi isso ha muito tempo atrás. quem fez isso tem uma dezena de blogs toscos sobre os mais variados assuntos. Creio que só envolvermos alguém do google pra talvez conseguir bloquear algo, ou pelo menos descobrir quem é.

On Tuesday, October 31, 2017, felipe milagres <felipemilagres.x@gmail.com> wrote:

Boa tarde,

Hoje está sendo um daqueles dias de bobeira e pesquisei meu email no google para ver no que dava e encontrei isso: http://lettheworldturn.blogspot.ca/2017/08/

Existe algo que possa ser feito para isso não rolar? nossas perguntas/respostas expostas aberto ao google com email e tudo

--
You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


--

Maicon Strey
Novo Hamburgo - RS - Brasil
------------------
------------------

--
You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

  • Digg
  • Del.icio.us
  • StumbleUpon
  • Reddit
  • RSS

[androidbrasil-dev] [off-topic] perguntas expostas no google

Boa tarde,

Hoje está sendo um daqueles dias de bobeira e pesquisei meu email no google para ver no que dava e encontrei isso: http://lettheworldturn.blogspot.ca/2017/08/

Existe algo que possa ser feito para isso não rolar? nossas perguntas/respostas expostas aberto ao google com email e tudo

--
You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

  • Digg
  • Del.icio.us
  • StumbleUpon
  • Reddit
  • RSS

[androidbrasil-dev] If you type 1+2+3 into your iPhone’s calculator on iOS 11, you probably won’t get 6

--
You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

  • Digg
  • Del.icio.us
  • StumbleUpon
  • Reddit
  • RSS

[androidbrasil-dev] Background do FAB em cima da action bar ou Toolbar

Bom dia galera.


Bom, eu gostaria de saber como eu faço um FAB parecido com esse da imagem em anexo.
Na verdade o que está me dando dor de cabeça é a imagem de background, eu não consigo fazer com que ela fique por cima da actionbar/toolbar.

Desde já agradeço.



--
You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

  • Digg
  • Del.icio.us
  • StumbleUpon
  • Reddit
  • RSS

Re: [androidbrasil-dev] Gradle 3.0 com AndroidAnnotat

Legal, funcinou show..

Obrigado

On Fri, Oct 27, 2017 at 1:56 PM, wesley lima da silva <fioalpha@gmail.com> wrote:

2017-10-27 13:54 GMT-02:00 Wellington Costa <wellington.costa128@gmail.com>:
Isso. Os "apt" você deve substituir por "annotationProcessor".

Inclusive os "compile" devem ser substituídos por "implementation".

On Oct 27, 2017 13:52, "Tiago Grillo" <tijgrillo@gmail.com> wrote:
Deu certo Wellington ai eu tiro tudo que era apt né.

Muito Obrigado

On Fri, Oct 27, 2017 at 12:38 PM, Wellington Costa <wellington.costa128@gmail.com> wrote:
As dependências estão assim?

annotationProcessor 'org.androidannotations:androidannotations:4.3.1'  compile 'org.androidannotations:androidannotations-api:4.3.1'



2017-10-27 11:31 GMT-03:00 Tiago Grillo <tijgrillo@gmail.com>:
Olá,

    Alguém já fez update para o Android Studio 3 e atualizou o gradle 3.0 também, ao fazer isto ele para de funcionar com o AndroidAnnotation.

Error:android-apt plugin is incompatible with the Android Gradle plugin.  Please use 'annotationProcessor' configuration instead.

   Ai até coloco a no dependencias um annotationProcessor como achei na net, mas num rola.

   Alguém esta passando por isto?

Obrigado,
Tiago

--
You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.



--
Atenciosamente,

Wellington Costa Pereira
Pós Graduando em Engenharia de Software – UECE
Desenvolvedor de Software – IVIA

--
You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

  • Digg
  • Del.icio.us
  • StumbleUpon
  • Reddit
  • RSS

Re: [androidbrasil-dev] Gradle 3.0 com AndroidAnnotat


2017-10-27 13:54 GMT-02:00 Wellington Costa <wellington.costa128@gmail.com>:
Isso. Os "apt" você deve substituir por "annotationProcessor".

Inclusive os "compile" devem ser substituídos por "implementation".

On Oct 27, 2017 13:52, "Tiago Grillo" <tijgrillo@gmail.com> wrote:
Deu certo Wellington ai eu tiro tudo que era apt né.

Muito Obrigado

On Fri, Oct 27, 2017 at 12:38 PM, Wellington Costa <wellington.costa128@gmail.com> wrote:
As dependências estão assim?

annotationProcessor 'org.androidannotations:androidannotations:4.3.1'  compile 'org.androidannotations:androidannotations-api:4.3.1'



2017-10-27 11:31 GMT-03:00 Tiago Grillo <tijgrillo@gmail.com>:
Olá,

    Alguém já fez update para o Android Studio 3 e atualizou o gradle 3.0 também, ao fazer isto ele para de funcionar com o AndroidAnnotation.

Error:android-apt plugin is incompatible with the Android Gradle plugin.  Please use 'annotationProcessor' configuration instead.

   Ai até coloco a no dependencias um annotationProcessor como achei na net, mas num rola.

   Alguém esta passando por isto?

Obrigado,
Tiago

--
You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.



--
Atenciosamente,

Wellington Costa Pereira
Pós Graduando em Engenharia de Software – UECE
Desenvolvedor de Software – IVIA

--
You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

  • Digg
  • Del.icio.us
  • StumbleUpon
  • Reddit
  • RSS

Re: [androidbrasil-dev] Gradle 3.0 com AndroidAnnotat

Isso. Os "apt" você deve substituir por "annotationProcessor".

Inclusive os "compile" devem ser substituídos por "implementation".

On Oct 27, 2017 13:52, "Tiago Grillo" <tijgrillo@gmail.com> wrote:
Deu certo Wellington ai eu tiro tudo que era apt né.

Muito Obrigado

On Fri, Oct 27, 2017 at 12:38 PM, Wellington Costa <wellington.costa128@gmail.com> wrote:
As dependências estão assim?

annotationProcessor 'org.androidannotations:androidannotations:4.3.1'  compile 'org.androidannotations:androidannotations-api:4.3.1'



2017-10-27 11:31 GMT-03:00 Tiago Grillo <tijgrillo@gmail.com>:
Olá,

    Alguém já fez update para o Android Studio 3 e atualizou o gradle 3.0 também, ao fazer isto ele para de funcionar com o AndroidAnnotation.

Error:android-apt plugin is incompatible with the Android Gradle plugin.  Please use 'annotationProcessor' configuration instead.

   Ai até coloco a no dependencias um annotationProcessor como achei na net, mas num rola.

   Alguém esta passando por isto?

Obrigado,
Tiago

--
You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.



--
Atenciosamente,

Wellington Costa Pereira
Pós Graduando em Engenharia de Software – UECE
Desenvolvedor de Software – IVIA

--
You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

  • Digg
  • Del.icio.us
  • StumbleUpon
  • Reddit
  • RSS

Re: [androidbrasil-dev] Gradle 3.0 com AndroidAnnotat

Deu certo Wellington ai eu tiro tudo que era apt né.

Muito Obrigado

On Fri, Oct 27, 2017 at 12:38 PM, Wellington Costa <wellington.costa128@gmail.com> wrote:
As dependências estão assim?

annotationProcessor 'org.androidannotations:androidannotations:4.3.1'  compile 'org.androidannotations:androidannotations-api:4.3.1'



2017-10-27 11:31 GMT-03:00 Tiago Grillo <tijgrillo@gmail.com>:
Olá,

    Alguém já fez update para o Android Studio 3 e atualizou o gradle 3.0 também, ao fazer isto ele para de funcionar com o AndroidAnnotation.

Error:android-apt plugin is incompatible with the Android Gradle plugin.  Please use 'annotationProcessor' configuration instead.

   Ai até coloco a no dependencias um annotationProcessor como achei na net, mas num rola.

   Alguém esta passando por isto?

Obrigado,
Tiago

--
You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.



--
Atenciosamente,

Wellington Costa Pereira
Pós Graduando em Engenharia de Software – UECE
Desenvolvedor de Software – IVIA

--
You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

  • Digg
  • Del.icio.us
  • StumbleUpon
  • Reddit
  • RSS

Re: [androidbrasil-dev] Gradle 3.0 com AndroidAnnotat

As dependências estão assim?

annotationProcessor 'org.androidannotations:androidannotations:4.3.1'  compile 'org.androidannotations:androidannotations-api:4.3.1'



2017-10-27 11:31 GMT-03:00 Tiago Grillo <tijgrillo@gmail.com>:
Olá,

    Alguém já fez update para o Android Studio 3 e atualizou o gradle 3.0 também, ao fazer isto ele para de funcionar com o AndroidAnnotation.

Error:android-apt plugin is incompatible with the Android Gradle plugin.  Please use 'annotationProcessor' configuration instead.

   Ai até coloco a no dependencias um annotationProcessor como achei na net, mas num rola.

   Alguém esta passando por isto?

Obrigado,
Tiago

--
You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.



--
Atenciosamente,

Wellington Costa Pereira
Pós Graduando em Engenharia de Software – UECE
Desenvolvedor de Software – IVIA

--
You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

  • Digg
  • Del.icio.us
  • StumbleUpon
  • Reddit
  • RSS

[androidbrasil-dev] Gradle 3.0 com AndroidAnnotat

Olá,

    Alguém já fez update para o Android Studio 3 e atualizou o gradle 3.0 também, ao fazer isto ele para de funcionar com o AndroidAnnotation.

Error:android-apt plugin is incompatible with the Android Gradle plugin.  Please use 'annotationProcessor' configuration instead.

   Ai até coloco a no dependencias um annotationProcessor como achei na net, mas num rola.

   Alguém esta passando por isto?

Obrigado,
Tiago

--
You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

  • Digg
  • Del.icio.us
  • StumbleUpon
  • Reddit
  • RSS

[androidbrasil-dev] Re: [vaga][São Paulo] Desenvolvedor Android Pleno-Sênior ( 2 vagas)

Pode ser remota?

Em quarta-feira, 25 de outubro de 2017 17:55:19 UTC-3, Jonas Kaffka escreveu:
Estamos atendendo a empresa de tecnologia, genuinamente  especializada em projetos  para mobile, presente há mais de 5 anos no mercado.
Buscamos hoje para seu quadro efetivo 

2 desenvolvedores  android  pleno ou sênior.


Atividades:

Os profissionais  farão parte de equipe de empresa estruturada com mais de 5 anos de mercado , atuando focada em desenvolvimento mobile



    Requisitos:

    • Experiencia com Android  Nativo;
    • Atuação profissional anterior com  desenvolvimento mobile;
    • Conhecimentos necessários:  Android Studio, material design,RxJava, Product Flavor, Kotlin, testes unitários, 
    • Dinamismo, iniciativa, proatividade.

    Estamos   com vagas  para   desenvolvedor   pleno  e sênior  em função  da ampliação do time atual da empresa

    Contratação  CLT ou PJ com pacote completo de benefícios.


    Gostou da vaga?  Envie seu curriculo para jon...@holdenrh.com.br ou cadastre-se em https://holden.compleo.com.br/Visualizar/19417


    Abraço,


    Jonas Kaffka


    --
    You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.

    • Digg
    • Del.icio.us
    • StumbleUpon
    • Reddit
    • RSS

    [androidbrasil-dev] [vaga][São Paulo] Desenvolvedor Android Pleno-Sênior ( 2 vagas)

    Estamos atendendo a empresa de tecnologia, genuinamente  especializada em projetos  para mobile, presente há mais de 5 anos no mercado.
    Buscamos hoje para seu quadro efetivo 

    2 desenvolvedores  android  pleno ou sênior.


    Atividades:

    Os profissionais  farão parte de equipe de empresa estruturada com mais de 5 anos de mercado , atuando focada em desenvolvimento mobile



      Requisitos:

      • Experiencia com Android  Nativo;
      • Atuação profissional anterior com  desenvolvimento mobile;
      • Conhecimentos necessários:  Android Studio, material design,RxJava, Product Flavor, Kotlin, testes unitários, 
      • Dinamismo, iniciativa, proatividade.

      Estamos   com vagas  para   desenvolvedor   pleno  e sênior  em função  da ampliação do time atual da empresa

      Contratação  CLT ou PJ com pacote completo de benefícios.


      Gostou da vaga?  Envie seu curriculo para jonask@holdenrh.com.br ou cadastre-se em https://holden.compleo.com.br/Visualizar/19417


      Abraço,


      Jonas Kaffka


      --
      You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
      For more options, visit https://groups.google.com/d/optout.

      • Digg
      • Del.icio.us
      • StumbleUpon
      • Reddit
      • RSS

      Re: [androidbrasil-dev] Problema com AppCompart num projeto Eclipse

      😎

      Em 25 de outubro de 2017 16:13, wesley lima da silva <fioalpha@gmail.com> escreveu:
      👍

      Em 25 de outubro de 2017 17:04, Marcelo Alves <malves.info@gmail.com> escreveu:
      show! Parabéns! 

      Em qua, 25 de out de 2017 às 14:18, Felipe Aron <felipearon@gmail.com> escreveu:
      Aí galera, DEU CERTO!! \o/

      No final foi bem mais fácil do que imaginava.

      Tive apenas de arrumar o encoding de algumas frases e remover as classes $$ViewInjector criadas na migração.

      Importei a lib como módulo e tudo rodando numa boa!! :)

      Valeu pessoal pela ajuda, 6 são feras!!

      Em 24 de outubro de 2017 17:26, Felipe Aron <felipearon@gmail.com> escreveu:
      Galera, 

      Eu tenho um projeto (library) que faz parte do App.

      Para jogar esse projeto lib lá no Studio, só fazer a importação automática, igual fiz aqui com o projeto App?

      E para linkar essa Lib no projeto app? Como fazer?

      Em 24 de outubro de 2017 16:31, 'Vitor Almeida da Silva' via Android Brasil - Dev <androidbrasil-dev@googlegroups.com> escreveu:
      Tomara que dê certo, nos avise se precisar de alguma força.

      Quando eu realizei a migração de um projeto pessoal para o Android Studio (projeto muito pequeno de nicho sem muitas bibliotecas), também tive alguns problemas pequenos e acabei realizando o processo manualmente classe a classe.


      Mas no geral foi bem rápido.

      On Tuesday, October 24, 2017 at 3:52:49 PM UTC-2, Felipe Aron wrote:
      Bom, importei o projeto e a minha lib.

      To arrumando a lib, que deu alguns erros de encoding. Mas tá quase lá.

      Em 24 de outubro de 2017 15:30, Klecios Cronemberger <wkac...@gmail.com> escreveu:
      Na importação vai muito lixo. Eu fui copiando classe por classe. 

      Em ter, 24 de out de 2017 às 2:19 PM, Felipe Aron <felip...@gmail.com> escreveu:
      Hum, legal @Willian bom saber. 

      Vou fazer o teste aqui. To importando conforme a documentação, porém achei meio confuso.

      Se enrolar muito, vou criar um novo projeto, ai jogo as coisas nele. 

      Em 24 de outubro de 2017 15:00, Willian do Amor <will...@gmail.com> escreveu:
      Eu achei tranquilo a migração, porém não consegui fazer funcionar da maneira com explica na documentação. Copiei as classes e as libs manualmente para dentro do Studio na época.

      Em 24/10/2017 14:50, "Felipe Aron" <felip...@gmail.com> escreveu:
      Ok Ok galera, vocês venceram rs (consegui convencer o boss), bora migrar.

      Agora quero ver a "complexidade" dessa migração. Vamos ver se vai ser tranquila.

      O projeto em si é pequeno, poucas telas, porém tem diversas libs:

      > activation.jar
      > additionnal.jar
      > android-suport-v4.jar
      > butterknife-5.1.1.jar
      > greendao-1.3.1.jar
      > gson-2.2.4.jar
      > joda-time-2.3.jar
      > ksoap2-android-assembly-3.3.0-jar-with-dependencies.jar
      > mail.jar

      Bora lá né... Seguir o tutorial.

      Em 24 de outubro de 2017 10:53, 'Vitor Almeida da Silva' via Android Brasil - Dev <androidb...@googlegroups.com> escreveu:
      Olá @Felipe.

      Acho a sugestão do @Wesley válida não apenas por uma questão de suporte à ferramenta mas sim por suporte ao seu app para o cliente no futuro. Se você não realizar esta migração cedo ou tarde estará engessado com erros de ferramenta que não serão corrigidos e gastará tempo correndo atrás de problemas que não teria após a migração realizada para o Android Studio.

      Entretanto conforme você comentou aparentemente o custo/benefício da migração não compensa no momento, neste caso em relação ao erro especificado: "'@style/Theme.AppCompat.Light.DarkActionBar'" significa aparentemente que o processo de build não está ou encontrando a bibilioteca AppCompat ou que o estilo mencionado não está disponível.

      Para tentar resolver o problema recomendo você verificar os passos abaixo:

       - qual API level você está querendo compilar o projeto (e qual a versão mínima)?
       - [gambiarra] abrir este estilo no Android Studio, copiar (ou estilos realcionados) e colar no seu estilo da aplicação pra tentar forçar a ter o estilo no projeto (isto considerando que o projeto está encontrando a AppCompat).
       - verificar se as configurações do SDK do Android no Eclipse estão corretas.

      PS: estou falando tudo por cima com as informações que você passou (não sabemos o tamanho e complexidade do projeto). Minha recomendação é você realmente tentar a migração pra ver na prática se compensa ou não o custo benefício (às vezes você não terá tantos problemas quanto imagina).

      Abs,
      Vitor Almeida da Silva.

      On Monday, October 23, 2017 at 2:41:22 PM UTC-2, Felipe Aron wrote:
      Até entendo a questão de migrar para Studio, ferramenta "desatualizada" etc.

      A questão @Wesley é que é um projeto de cliente, que preciso entregar o quanto antes. 

      A manutenção que preciso fazer é rápida e simples, basicamente adicionar um novo campo e alterar uma regra.

      Migrar para o Studio, é quase certo que vai dar erro, vai precisar de ajustes, etc, e isso custa $$$, e cliente não vai querer pagar (e nós também não).

      Preciso resolver pelo Eclipse para liberar para o cliente.

      Se fosse um projeto pessoal meu, não ligaria de "perder tempo" migrando e testando.

      Em 23 de outubro de 2017 14:11, wesley lima da silva <fioa...@gmail.com> escreveu:
      @Felipe, desculpa mais acho que não muito claro com vc, hoje não existe mais suporta para Eclipse, ficar com uma ferramento aonde não tem mais suporte não serve de nada. Migra para Android Studio não é dificil mais pode acontecer algum problema no caminho, mais um dia voce vai precisar mudar. Em questões de lib eh bem mais facil voce atualiza, as biblioteca de terceiro que vc tem eh so declarar no gradle e a sua vc pode importa via jar ou fazer migrar o projeto para  Android Studio.


      Continuo falando migra para Android Studio.

      Att







      Em 23 de outubro de 2017 13:50, Rudson Lima <rudso...@gmail.com> escreveu:
      As vezes a galera daqui se fazem de doido pra cagar no sala. Dizer "Migra para Android Studio" não resolvi o projeto do colega. 

      Sabe se a empresa quer isso? Sabe se o cliente quer isso? Sabe se ele pode fazer isso? 

      Vamos focar mais em ajudar galera 🤗.

      @Felipe. Tenta refazer o import da appCompat no projeto, testa utilizando um .jar, clear no projeto e etc. 

      Boa sorte. 

      Em 23 de out de 2017 12:44 PM, "Marcelo Alves" <malve...@gmail.com> escreveu:
      Esquece o Eclipse! :P

      Em seg, 23 de out de 2017 às 11:42, wesley lima da silva <fioa...@gmail.com> escreveu:
      Blz cara,
      IDE!! Migra o projeto para Android Studio.

      Att

      2017-10-23 13:40 GMT-02:00 Felipe Aron <felip...@gmail.com>:
      Fala galera beleza?

      Eu preciso mexer num projeto aqui que estava "empoeirado" e ao compilar pelo eclipse, está dando o seguinte erro:

      No resource found that matches the given name '@style/Theme.AppCompat.Light.DarkActionBar'.

      Antigamente, quando desenvolvi o App, bastava eu abrir o projeto AppCompat do SDK, porém agora não tem mais.

      Como faço para resolver isso? Alguém faz ideia?

      --
      Programador & Empreendedor Digital

      --
      You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-...@googlegroups.com.
      For more options, visit https://groups.google.com/d/optout.

      --
      You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-...@googlegroups.com.
      For more options, visit https://groups.google.com/d/optout.

      --
      You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-...@googlegroups.com.
      For more options, visit https://groups.google.com/d/optout.

      --
      You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-...@googlegroups.com.
      For more options, visit https://groups.google.com/d/optout.

      --
      You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-...@googlegroups.com.
      For more options, visit https://groups.google.com/d/optout.



      --
      Programador & Empreendedor Digital

      --
      You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-...@googlegroups.com.
      For more options, visit https://groups.google.com/d/optout.



      --
      Programador & Empreendedor Digital

      --
      You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-...@googlegroups.com.
      For more options, visit https://groups.google.com/d/optout.

      --
      You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-...@googlegroups.com.
      For more options, visit https://groups.google.com/d/optout.



      --
      Programador & Empreendedor Digital

      --
      You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-...@googlegroups.com.
      For more options, visit https://groups.google.com/d/optout.
      --

      ---~--~----~------~-----~--~----
      Klecios Cronemberger
      ...

      --
      You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-...@googlegroups.com.
      For more options, visit https://groups.google.com/d/optout.



      --
      Programador & Empreendedor Digital

      --
      You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
      For more options, visit https://groups.google.com/d/optout.



      --
      Programador & Empreendedor Digital



      --
      Programador & Empreendedor Digital

      --
      You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
      For more options, visit https://groups.google.com/d/optout.

      --
      You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
      For more options, visit https://groups.google.com/d/optout.

      --
      You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
      For more options, visit https://groups.google.com/d/optout.



      --
      Rudson Lima ( live-O ) Desenvolvedor Android
      Contato +55 85 87050560 - Fortaleza-ce
      Social facebook | google+ | linkedin

      --
      You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
      For more options, visit https://groups.google.com/d/optout.

      • Digg
      • Del.icio.us
      • StumbleUpon
      • Reddit
      • RSS

      Re: [androidbrasil-dev] Problema com AppCompart num projeto Eclipse

      👍

      Em 25 de outubro de 2017 17:04, Marcelo Alves <malves.info@gmail.com> escreveu:
      show! Parabéns! 

      Em qua, 25 de out de 2017 às 14:18, Felipe Aron <felipearon@gmail.com> escreveu:
      Aí galera, DEU CERTO!! \o/

      No final foi bem mais fácil do que imaginava.

      Tive apenas de arrumar o encoding de algumas frases e remover as classes $$ViewInjector criadas na migração.

      Importei a lib como módulo e tudo rodando numa boa!! :)

      Valeu pessoal pela ajuda, 6 são feras!!

      Em 24 de outubro de 2017 17:26, Felipe Aron <felipearon@gmail.com> escreveu:
      Galera, 

      Eu tenho um projeto (library) que faz parte do App.

      Para jogar esse projeto lib lá no Studio, só fazer a importação automática, igual fiz aqui com o projeto App?

      E para linkar essa Lib no projeto app? Como fazer?

      Em 24 de outubro de 2017 16:31, 'Vitor Almeida da Silva' via Android Brasil - Dev <androidbrasil-dev@googlegroups.com> escreveu:
      Tomara que dê certo, nos avise se precisar de alguma força.

      Quando eu realizei a migração de um projeto pessoal para o Android Studio (projeto muito pequeno de nicho sem muitas bibliotecas), também tive alguns problemas pequenos e acabei realizando o processo manualmente classe a classe.


      Mas no geral foi bem rápido.

      On Tuesday, October 24, 2017 at 3:52:49 PM UTC-2, Felipe Aron wrote:
      Bom, importei o projeto e a minha lib.

      To arrumando a lib, que deu alguns erros de encoding. Mas tá quase lá.

      Em 24 de outubro de 2017 15:30, Klecios Cronemberger <wkac...@gmail.com> escreveu:
      Na importação vai muito lixo. Eu fui copiando classe por classe. 

      Em ter, 24 de out de 2017 às 2:19 PM, Felipe Aron <felip...@gmail.com> escreveu:
      Hum, legal @Willian bom saber. 

      Vou fazer o teste aqui. To importando conforme a documentação, porém achei meio confuso.

      Se enrolar muito, vou criar um novo projeto, ai jogo as coisas nele. 

      Em 24 de outubro de 2017 15:00, Willian do Amor <will...@gmail.com> escreveu:
      Eu achei tranquilo a migração, porém não consegui fazer funcionar da maneira com explica na documentação. Copiei as classes e as libs manualmente para dentro do Studio na época.

      Em 24/10/2017 14:50, "Felipe Aron" <felip...@gmail.com> escreveu:
      Ok Ok galera, vocês venceram rs (consegui convencer o boss), bora migrar.

      Agora quero ver a "complexidade" dessa migração. Vamos ver se vai ser tranquila.

      O projeto em si é pequeno, poucas telas, porém tem diversas libs:

      > activation.jar
      > additionnal.jar
      > android-suport-v4.jar
      > butterknife-5.1.1.jar
      > greendao-1.3.1.jar
      > gson-2.2.4.jar
      > joda-time-2.3.jar
      > ksoap2-android-assembly-3.3.0-jar-with-dependencies.jar
      > mail.jar

      Bora lá né... Seguir o tutorial.

      Em 24 de outubro de 2017 10:53, 'Vitor Almeida da Silva' via Android Brasil - Dev <androidb...@googlegroups.com> escreveu:
      Olá @Felipe.

      Acho a sugestão do @Wesley válida não apenas por uma questão de suporte à ferramenta mas sim por suporte ao seu app para o cliente no futuro. Se você não realizar esta migração cedo ou tarde estará engessado com erros de ferramenta que não serão corrigidos e gastará tempo correndo atrás de problemas que não teria após a migração realizada para o Android Studio.

      Entretanto conforme você comentou aparentemente o custo/benefício da migração não compensa no momento, neste caso em relação ao erro especificado: "'@style/Theme.AppCompat.Light.DarkActionBar'" significa aparentemente que o processo de build não está ou encontrando a bibilioteca AppCompat ou que o estilo mencionado não está disponível.

      Para tentar resolver o problema recomendo você verificar os passos abaixo:

       - qual API level você está querendo compilar o projeto (e qual a versão mínima)?
       - [gambiarra] abrir este estilo no Android Studio, copiar (ou estilos realcionados) e colar no seu estilo da aplicação pra tentar forçar a ter o estilo no projeto (isto considerando que o projeto está encontrando a AppCompat).
       - verificar se as configurações do SDK do Android no Eclipse estão corretas.

      PS: estou falando tudo por cima com as informações que você passou (não sabemos o tamanho e complexidade do projeto). Minha recomendação é você realmente tentar a migração pra ver na prática se compensa ou não o custo benefício (às vezes você não terá tantos problemas quanto imagina).

      Abs,
      Vitor Almeida da Silva.

      On Monday, October 23, 2017 at 2:41:22 PM UTC-2, Felipe Aron wrote:
      Até entendo a questão de migrar para Studio, ferramenta "desatualizada" etc.

      A questão @Wesley é que é um projeto de cliente, que preciso entregar o quanto antes. 

      A manutenção que preciso fazer é rápida e simples, basicamente adicionar um novo campo e alterar uma regra.

      Migrar para o Studio, é quase certo que vai dar erro, vai precisar de ajustes, etc, e isso custa $$$, e cliente não vai querer pagar (e nós também não).

      Preciso resolver pelo Eclipse para liberar para o cliente.

      Se fosse um projeto pessoal meu, não ligaria de "perder tempo" migrando e testando.

      Em 23 de outubro de 2017 14:11, wesley lima da silva <fioa...@gmail.com> escreveu:
      @Felipe, desculpa mais acho que não muito claro com vc, hoje não existe mais suporta para Eclipse, ficar com uma ferramento aonde não tem mais suporte não serve de nada. Migra para Android Studio não é dificil mais pode acontecer algum problema no caminho, mais um dia voce vai precisar mudar. Em questões de lib eh bem mais facil voce atualiza, as biblioteca de terceiro que vc tem eh so declarar no gradle e a sua vc pode importa via jar ou fazer migrar o projeto para  Android Studio.


      Continuo falando migra para Android Studio.

      Att







      Em 23 de outubro de 2017 13:50, Rudson Lima <rudso...@gmail.com> escreveu:
      As vezes a galera daqui se fazem de doido pra cagar no sala. Dizer "Migra para Android Studio" não resolvi o projeto do colega. 

      Sabe se a empresa quer isso? Sabe se o cliente quer isso? Sabe se ele pode fazer isso? 

      Vamos focar mais em ajudar galera 🤗.

      @Felipe. Tenta refazer o import da appCompat no projeto, testa utilizando um .jar, clear no projeto e etc. 

      Boa sorte. 

      Em 23 de out de 2017 12:44 PM, "Marcelo Alves" <malve...@gmail.com> escreveu:
      Esquece o Eclipse! :P

      Em seg, 23 de out de 2017 às 11:42, wesley lima da silva <fioa...@gmail.com> escreveu:
      Blz cara,
      IDE!! Migra o projeto para Android Studio.

      Att

      2017-10-23 13:40 GMT-02:00 Felipe Aron <felip...@gmail.com>:
      Fala galera beleza?

      Eu preciso mexer num projeto aqui que estava "empoeirado" e ao compilar pelo eclipse, está dando o seguinte erro:

      No resource found that matches the given name '@style/Theme.AppCompat.Light.DarkActionBar'.

      Antigamente, quando desenvolvi o App, bastava eu abrir o projeto AppCompat do SDK, porém agora não tem mais.

      Como faço para resolver isso? Alguém faz ideia?

      --
      Programador & Empreendedor Digital

      --
      You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-...@googlegroups.com.
      For more options, visit https://groups.google.com/d/optout.

      --
      You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-...@googlegroups.com.
      For more options, visit https://groups.google.com/d/optout.

      --
      You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-...@googlegroups.com.
      For more options, visit https://groups.google.com/d/optout.

      --
      You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-...@googlegroups.com.
      For more options, visit https://groups.google.com/d/optout.

      --
      You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-...@googlegroups.com.
      For more options, visit https://groups.google.com/d/optout.



      --
      Programador & Empreendedor Digital

      --
      You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-...@googlegroups.com.
      For more options, visit https://groups.google.com/d/optout.



      --
      Programador & Empreendedor Digital

      --
      You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-...@googlegroups.com.
      For more options, visit https://groups.google.com/d/optout.

      --
      You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-...@googlegroups.com.
      For more options, visit https://groups.google.com/d/optout.



      --
      Programador & Empreendedor Digital

      --
      You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-...@googlegroups.com.
      For more options, visit https://groups.google.com/d/optout.
      --

      ---~--~----~------~-----~--~----
      Klecios Cronemberger
      ...

      --
      You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-...@googlegroups.com.
      For more options, visit https://groups.google.com/d/optout.



      --
      Programador & Empreendedor Digital

      --
      You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
      For more options, visit https://groups.google.com/d/optout.



      --
      Programador & Empreendedor Digital



      --
      Programador & Empreendedor Digital

      --
      You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
      For more options, visit https://groups.google.com/d/optout.

      --
      You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
      For more options, visit https://groups.google.com/d/optout.

      --
      You received this message because you are subscribed to the Google Groups "Android Brasil - Dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to androidbrasil-dev+unsubscribe@googlegroups.com.
      For more options, visit https://groups.google.com/d/optout.

      • Digg
      • Del.icio.us
      • StumbleUpon
      • Reddit
      • RSS